lkml.org 
[lkml]   [2010]   [Dec]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    From
    Subject[PATCH] [118/223] ALSA: hda - Use ALC_INIT_DEFAULT for really default initialization
    Date
    2.6.35-longterm review patch.  If anyone has any objections, please let me know.

    ------------------
    From: Takashi Iwai <tiwai@suse.de>

    commit 5a8cfb4e8ae317d283f84122ed20faa069c5e0c4 upstream.

    When SKU assid gives no valid bits for 0x38, the driver didn't take
    any action, so far. This resulted in the missing initialization for
    external amps, etc, thus the silent output in the end.

    Especially users hit this problem on ALC888 newly since 2.6.35,
    where the driver doesn't force to use ALC_INIT_DEFAULT any more.

    This patch sets the default initialization scheme to use
    ALC_INIT_DEFAULT when no valid bits are set for SKU assid.

    Reference:
    https://bugzilla.redhat.com/show_bug.cgi?id=657388

    Reported-and-tested-by: Kyle McMartin <kyle@redhat.com>
    Signed-off-by: Takashi Iwai <tiwai@suse.de>
    Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
    Signed-off-by: Andi Kleen <ak@linux.intel.com>

    ---
    sound/pci/hda/patch_realtek.c | 1 +
    1 file changed, 1 insertion(+)

    Index: linux/sound/pci/hda/patch_realtek.c
    ===================================================================
    --- linux.orig/sound/pci/hda/patch_realtek.c
    +++ linux/sound/pci/hda/patch_realtek.c
    @@ -1391,6 +1391,7 @@ do_sku:
    spec->init_amp = ALC_INIT_GPIO3;
    break;
    case 5:
    + default:
    spec->init_amp = ALC_INIT_DEFAULT;
    break;
    }

    \
     
     \ /
      Last update: 2010-12-13 01:11    [W:4.061 / U:0.228 seconds]
    ©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site