lkml.org 
[lkml]   [2010]   [Nov]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH] x86-64: more fixes and cleanup to AMD Fam10 MMCONF enabling
    >>> On 08.11.10 at 17:13, "H. Peter Anvin" <hpa@zytor.com> wrote:
    > On 11/05/2010 03:59 AM, Jan Beulich wrote:
    >>
    >> --- 2.6.37-rc1-x86_64-mmconf-fam10h.orig/arch/x86/kernel/mmconf-fam10h_64.c
    >> +++ 2.6.37-rc1-x86_64-mmconf-fam10h/arch/x86/kernel/mmconf-fam10h_64.c
    >> @@ -43,7 +43,7 @@ static int __cpuinit cmp_range(const voi
    >> return start1 - start2;
    >> }
    >>
    >> -#define UNIT (1ULL << (5 + 3 + 12))
    >> +#define UNIT (1ULL << FAM10H_MMIO_CONF_BASE_SHIFT)
    >> #define MASK (~(UNIT - 1))
    >> #define SIZE (UNIT << 8)
    >
    > Could we avoid macros named UNIT, MASK, and SIZE at all? I realize
    > they're already in the code, but still...

    I could understand if these were definition in a header, but why
    do you think we need to have unnecessarily long identifiers (e.g.
    by prefixing all of the defines here with FAM10H_MMIO_CONF_BASE_)
    in places like this? After all, one of the two goals of using a macro
    here at all is to keep things small and simple...

    But sure, if just the names hinder acceptance, I can fold this and
    the original patches together and use less ambiguous names.

    Jan



    \
     
     \ /
      Last update: 2010-11-08 17:47    [W:0.020 / U:61.184 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site