[lkml]   [2010]   [Oct]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 07/17] Make dentry::d_mounted into a more general field for special function dirs
On Thu, Sep 30, 2010 at 07:15:31PM +0100, David Howells wrote:
> Make the d_mounted field in struct dentry into a more general field for special
> function directories such as mountpoints and autofs substructures.
> d_mounted is renamed d_managed, and that is split into three fields:
> (*) #define DMANAGED_MOUNTPOINT 0x0fffffff

No matter how hard I try, I always read this as "DAMAGED". Which I
can't help but imagine subliminally influences the reader's opinion of
the patches.

Of course I am excellent at naming things, see "chunkfs" and
"relatime". But some ideas for naming various concepts in this patch:



 \ /
  Last update: 2010-10-09 02:01    [from the cache]
©2003-2014 Jasper Spaans. hosted at Digital Ocean