lkml.org 
[lkml]   [2010]   [Oct]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: linux-next: Tree for October 28 (acpi_video)
> drivers/built-in.o: In function `acpi_video_bus_put_one_device':
> video.c:(.text+0x9d794): undefined reference to `backlight_device_unregister'

Invalid .config, as ACPI_VIDEO depends on BACKLIGHT_CLASS_DEVICE, which is not set.

This breakage is the infamous "select in Kconfig doesn't" bug,
which has apparently claimed a new victim, STUB_POULSBO:

(STUB_POULSBO && HAS_IOMEM && PCI && ACPI || DRM_I915 && <choice> &&
AGP_INTEL && ACPI || DRM_NOUVEAU && STAGING && !STAGING_EXCLUDE_BUILD &&
DRM && PCI && ACPI) selects ACPI_VIDEO which has unmet direct dependencies
(ACPI && X86 && BACKLIGHT_CLASS_DEVICE && VIDEO_OUTPUT_CONTROL && INPUT)
commit e26fd1199ebab0d469fc3e037da5932d382f0669
Author: Lee, Chun-Yi <joeyli.kernel@gmail.com>
Date: Wed Oct 20 13:51:19 2010 +0800

gpu: Add Intel GMA500(Poulsbo) Stub Driver

Currently, there have no GMA500(Poulsbo) native video driver to
support
intel opregion. So, use this stub driver to enable the acpi backlight
control sysfs entry files by requrest acpi_video_register.

[airlied: fix warnings]

Signed-off-by: Lee, Chun-Yi <jlee@novell.com>
Signed-off-by: Dave Airlie <airlied@redhat.com>



\
 
 \ /
  Last update: 2010-10-29 20:21    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site