lkml.org 
[lkml]   [2010]   [Oct]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
Subject[PATCH -next] pch_can: depends on PCI
From: Randy Dunlap <randy.dunlap@oracle.com>

Fix pch_can build when CONFIG_PCI is not enabled. It uses pci interfaces
and data structures, so it should depend on PCI.

drivers/net/can/pch_can.c:1044: error: implicit declaration of function 'pci_enable_msi'
drivers/net/can/pch_can.c:1079: error: implicit declaration of function 'pci_disable_msi'

Signed-off-by: Randy Dunlap <randy.dunlap@oracle.com>
---
drivers/net/can/Kconfig | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--- linux-next-20101025.orig/drivers/net/can/Kconfig
+++ linux-next-20101025/drivers/net/can/Kconfig
@@ -84,7 +84,7 @@ config CAN_FLEXCAN

config PCH_CAN
tristate "PCH CAN"
- depends on CAN_DEV
+ depends on CAN_DEV && PCI
---help---
This driver is for PCH CAN of Topcliff which is an IOH for x86
embedded processor.

\
 
 \ /
  Last update: 2010-10-26 01:43    [from the cache]
©2003-2011 Jasper Spaans