lkml.org 
[lkml]   [2010]   [Jan]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH -v5 0/38] x86: not use bootmem for x86
On 01/22/2010 01:24 AM, Yinghai Lu wrote:
> please check the patches regarding with early_res and bootmem
>
> it will use early_res instead of bootmem with x86 code.
> but still can use CONFIG_NO_BOOMEM to use bootmem or not
> so could make transistion more smoothly
>
> -v2: allocate vmemmap on one node together, and also seperate early_res
> -v3: make x86 32 bit support early_res to use bootmem too
> move related early_res to kernel/
> sparse vmemmap together: address Ingo.
> -v4: some patches could go with tip with acked-by Jesse
> radix and logical flat etc
> -v5: put back to 2 patches into this patch to make it consistent
> as linus pointed out that some place should replace size_t
> with resource_size_t, and acctually that is done already in
> those patches in pci/linux-next.
>

I have been looking at this patchset and tried it out; it has a build
failure because of a naming conflict:

/home/hpa/kernel/linux-2.6-tip.range/drivers/pci/hotplug/ibmphp_res.c:43: error:
conflicting types for ‘add_range’
/home/hpa/kernel/linux-2.6-tip.range/include/linux/range.h:9: note:
previous declaration of ‘add_range’ was here

"add_range" is static.

This makes me concerned that the naming is too generic. In particular,
we tend to prefer naming of the type subsystem_function(), so in this
case range_add() might be a more suitable naming scheme.

I'm going to spend more time on this patchset.

-hpa
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2010-01-26 01:45    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site