lkml.org 
[lkml]   [2009]   [Sep]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH v2 0/5] Use macros rather than hardcoding section names
Date
This patch series cleans up the kernel's explicit references to
.data.page_aligned, .bss.page_aligned, and .data.init_task to instead
use the standard macros for those sections.embly code.

This version of the patch series differs from the previous one in that
I've added a new patch that fixes breakage in the x86 linker script
caused indirectly by the last patch in the patch series.

This cleanup is in preparation for being able to change the names of
the .data.page_aligned and .bss.page_aligned sections to be
compatabible with -ffunction-sections -fdata-sections.

This patch series doesn't touch the kernel's linker scripts, only the
C and assembly files. I've now sent to the LKML patches cleaning up
all the architecture linker scripts as well; the total diffstat for
this section name cleanup project targeted at 2.6.32 is:
79 files changed, 339 insertions(+), 1446 deletions(-)

Joe Perches (1):
Use new __init_task_data macro in arch init_task.c files.

Tim Abbott (4):
kbuild: Don't define ALIGN and ENTRY when preprocessing linker
scripts.
Use macros for .bss.page_aligned section.
powerpc: remove unused __page_aligned definition.
Use macros for .data.page_aligned section.

arch/arm/kernel/init_task.c | 5 ++---
arch/avr32/kernel/init_task.c | 5 ++---
arch/avr32/mm/init.c | 4 +---
arch/cris/kernel/process.c | 5 ++---
arch/frv/kernel/init_task.c | 5 ++---
arch/h8300/kernel/init_task.c | 5 ++---
arch/ia64/kernel/init_task.c | 3 ++-
arch/m32r/kernel/init_task.c | 5 ++---
arch/m68k/kernel/process.c | 6 +++---
arch/m68knommu/kernel/init_task.c | 5 ++---
arch/microblaze/kernel/init_task.c | 5 ++---
arch/mips/kernel/init_task.c | 5 ++---
arch/mn10300/kernel/init_task.c | 5 ++---
arch/parisc/kernel/init_task.c | 4 ++--
arch/powerpc/include/asm/page_64.h | 8 --------
arch/powerpc/kernel/init_task.c | 5 ++---
arch/powerpc/kernel/machine_kexec_64.c | 5 +++--
arch/powerpc/kernel/vdso.c | 3 ++-
arch/powerpc/kernel/vdso32/vdso32_wrapper.S | 3 ++-
arch/powerpc/kernel/vdso64/vdso64_wrapper.S | 3 ++-
arch/s390/kernel/init_task.c | 5 ++---
arch/s390/kernel/vdso.c | 2 +-
arch/s390/kernel/vdso32/vdso32_wrapper.S | 3 ++-
arch/s390/kernel/vdso64/vdso64_wrapper.S | 3 ++-
arch/sh/kernel/init_task.c | 5 ++---
arch/sh/kernel/irq.c | 6 ++----
arch/sparc/kernel/init_task.c | 5 ++---
arch/um/kernel/init_task.c | 5 ++---
arch/x86/include/asm/cache.h | 4 +++-
arch/x86/kernel/head_32.S | 4 ++--
arch/x86/kernel/head_64.S | 2 +-
arch/x86/kernel/init_task.c | 5 ++---
arch/xtensa/kernel/head.S | 2 +-
arch/xtensa/kernel/init_task.c | 5 ++---
include/linux/linkage.h | 2 ++
scripts/Makefile.build | 3 ++-
36 files changed, 69 insertions(+), 86 deletions(-)



\
 
 \ /
  Last update: 2009-09-09 04:53    [W:0.097 / U:0.552 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site