lkml.org 
[lkml]   [2009]   [Aug]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 4/7] kfifo: rename kfifo_put... into kfifo_in... and kfifo_get... into kfifo_out...

Zitat von David Vrabel <david.vrabel@csr.com>:

> Joe Perches wrote:
>> On Wed, 2009-08-19 at 23:00 +0200, Stefani Seibold wrote:
>>> rename kfifo_put... into kfifo_in... to prevent miss use of old
>>> non in kernel-tree drivers
>>> ditto for kfifo_get... -> kfifo_out...
>>
>> I would have thought
>> kfifo_put -> kfifo_out
>> kfifo_get -> kfifo_in
>> but maybe that's just me.
>
> Use push and pull instead? In and out (whichever way) isn't obvious enough.
>
> David
>

As i wrote before: FIFO means first in/first out not first
pushed/first pulled nor first put/first get
It it logical.



\
 
 \ /
  Last update: 2009-08-20 12:05    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site