lkml.org 
[lkml]   [2009]   [Jul]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    SubjectRe: Null Pointer BUG in uhci_hcd
    Date
    On Wed July 8 2009, Alan Stern wrote:
    > On Wed, 8 Jul 2009, Michael S. Zick wrote:
    >
    > > But, then again, we might just get lucky:
    > > ehci_hcd 0000:00:10.4: Unlink after no-IRQ? Controller is probably using the wrong IRQ.
    > > usb 1-5: khubd timed out on ep0in len=18/64
    >
    > Like I've been telling you all along, the hardware isn't working.
    >

    That sounds very fragile.

    > I suspect it's worse than a simple interrupt-routing mistake.
    >

    I would not object to your removing that one mistake - that is one less
    to contend with.

    > > > > For more information enable CONFIG_USB_DEBUG and CONFIG_DEBUG_FS, then
    > > > > see what's sitting in the usb/uhci/* files in debugfs.
    > > > >
    > >

    Fours up-time - nothing written to dmesg since boot -
    Just the usual hard-lockup.

    Also - something in the combined fix/diagnostic patch
    disable any sensing of external usb events.
    So I couldn't very well poke devices at it. ;)

    > > Anything in particular to look for/at?
    >
    > Just post the contents of those files.
    >

    Will capture that information during this afternoon's testing.

    Mike
    > Alan Stern
    >
    >
    >




    \
     
     \ /
      Last update: 2009-07-08 22:25    [W:0.021 / U:29.656 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site