[lkml]   [2009]   [Jul]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [rfc][patch 1/3] fs: new truncate sequence
On Tue, Jul 07, 2009 at 09:29:11AM +0200, Peter Zijlstra wrote:
> On Mon, 2009-07-06 at 19:47 +0200, Nick Piggin wrote:
> > All good points. I don't know what name to use though -- your idea
> > of renaming ->truncate then reusing it is nice but people will cry
> > about breaking external modules. I'll call it ->setsize and defer
> > having to think about it for now.
> Changing the function signature should get them a compiler warning,
> aside from that I don't think we should really consider their feelings
> anyway ;-)

Well I don't much, but some people do. Anyway I think ->setsize is
actually quite a good name on 2nd thoughts ;)

 \ /
  Last update: 2009-07-07 10:51    [W:0.050 / U:13.020 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site