lkml.org 
[lkml]   [2009]   [Jul]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [Patch] btrfs: use file_remove_suid() after i_mutex is held
Arjan van de Ven wrote:
> On Mon, 6 Jul 2009 01:29:14 -0400
> Amerigo Wang <amwang@redhat.com> wrote:
>
>
>> file_remove_suid() should be called with i_mutex held,
>> file_update_time() too. So move them after mutex_lock().
>>
>> Plus, check the return value of kmalloc().
>>
>> Signed-off-by: WANG Cong <amwang@redhat.com>
>>
>> ---
>> diff --git a/fs/btrfs/file.c b/fs/btrfs/file.c
>> index 7c3cd24..cd36301 100644
>> --- a/fs/btrfs/file.c
>> +++ b/fs/btrfs/file.c
>> @@ -944,14 +944,17 @@ static ssize_t btrfs_file_write(struct file
>> *file, const char __user *buf, if (count == 0)
>> goto out_nolock;
>>
>> + mutex_lock(&inode->i_mutex);
>> +
>> err = file_remove_suid(file);
>> if (err)
>> - goto out_nolock;
>> + goto out;
>> file_update_time(file);
>>
>> pages = kmalloc(nrptrs * sizeof(struct page *), GFP_KERNEL);
>> + if (!pages)
>> + goto out;
>>
>>
> Hi,
>
> I don't think you can keep this at GFP_KERNEL once you hold i_mutex....
> very likely this needs to now turn into GFP_NOFS!
>

Good point!
Hmm, GFP_KERNEL adds __GFP_FS while GFP_NOFS not...
Just moving that kmalloc() up, before mutex_lock(), I think, can solve
this.

I will update this patch now...

Thanks!



\
 
 \ /
  Last update: 2009-07-06 08:27    [W:1.673 / U:0.392 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site