lkml.org 
[lkml]   [2009]   [Jul]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    SubjectRe: [RFC][patch 09/12] add xtime_shift and ntp_error_shift to struct timekeeper
    From
    Date
    On Wed, 2009-07-29 at 15:41 +0200, Martin Schwidefsky wrote:
    > plain text document attachment (timekeeper-shift.diff)
    > From: Martin Schwidefsky <schwidefsky@de.ibm.com>
    >
    > The xtime_nsec value in the timekeeper structure is shifted by a few
    > bits to improve precision. This happens to be the same value as the
    > clock->shift. To improve readability add xtime_shift to the timekeeper
    > and use it instead of the clock->shift. Likewise add ntp_error_shift
    > and replace all (NTP_SCALE_SHIFT - clock->shift) expressions.
    >
    > Cc: Ingo Molnar <mingo@elte.hu>
    > Cc: Thomas Gleixner <tglx@linutronix.de>
    > Cc: john stultz <johnstul@us.ibm.com>
    > Cc: Daniel Walker <dwalker@fifo99.com>
    > Signed-off-by: Martin Schwidefsky <schwidefsky@de.ibm.com>
    > ---
    > kernel/time/timekeeping.c | 33 ++++++++++++++++++---------------
    > 1 file changed, 18 insertions(+), 15 deletions(-)
    >
    > Index: linux-2.6/kernel/time/timekeeping.c
    > ===================================================================
    > --- linux-2.6.orig/kernel/time/timekeeping.c
    > +++ linux-2.6/kernel/time/timekeeping.c
    > @@ -27,6 +27,8 @@ struct timekeeper {
    > u32 raw_interval;
    > u64 xtime_nsec;
    > s64 ntp_error;
    > + int xtime_shift;
    > + int ntp_error_shift;
    > };

    I suspect ntp_error_shift is one of the lease intuitive values in the
    timekeeper structure. They all probably need nice comments explaining
    what they store, but especially this one.

    Something like:

    struct clocksource *clock; /* current clocksource used for timekeeping*/
    cycle_t cycle_interval; /* fixed chunk of cycles used in accumulation */
    u64 xtime_interval; /* number clock shifted nsecs accumulated per cycle_interval */
    u32 raw_interval; /* raw nsecs accumulated per cycle_interval */
    u64 xtime_nsec; /* clock shifted nsecs remainder not stored in xtime.tv_nsec */
    s64 ntp_error; /* Difference between accumulated time and NTP time in ntp shifted nsecs */
    int xtime_shift; /* The shift value of the current clocksource */
    int ntp_error_shift; /* Shift conversion between clock shifted nsecs and ntp shifted nsecs */


    Other then that this patch looks ok, but will need rigorous testing, as
    its very complicated and difficult to understand code thats being
    changed.

    thanks
    -john




    \
     
     \ /
      Last update: 2009-07-31 00:17    [W:0.024 / U:187.160 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site