lkml.org 
[lkml]   [2009]   [Jul]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [RFC v17][PATCH 10/60] c/r: make file_pos_read/write() public
a nitpick.

On Wed, 22 Jul 2009 05:59:32 -0400
Oren Laadan <orenl@librato.com> wrote:

> These two are used in the next patch when calling vfs_read/write()

> +static inline loff_t file_pos_read(struct file *file)
> +{
> + return file->f_pos;
> +}
> +
> +static inline void file_pos_write(struct file *file, loff_t pos)
> +{
> + file->f_pos = pos;
> +}
> +

I'm not sure but how about renaming this to
file_pos()
set_file_pos()
at moving this to global include file ?

Thanks,
-Kame



\
 
 \ /
  Last update: 2009-07-23 04:37    [W:0.231 / U:1.120 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site