lkml.org 
[lkml]   [2009]   [Jul]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.6.31-rc0-git: lsusb stopped working?
Hi!
> > > >
> > > > On thinkpad x60. Otherwise usb seems to work, including btusb dongle.
> > > >
> > > > /proc/bus/usb does not seem to exists.
> > >
> > > Newer (as in the past 2 years) versions of lsusb should not need
> > > /proc/bus/usb/
> > >
> > > What version of usbutils are you using?
> >
> > root@amd:/home/pavel# lsusb --version
> > lsusb (usbutils) 0.73
> > root@amd:/home/pavel#
> >
> > I may have done something stupid with not runing udev and linking
> > /proc/bus/usb to /dev, instead...
>
> the opensuse FACTORY tree now has a more modern version of usbutils in
> it, which works just fine without usbfs mounted.

Well, this is heavily hacked debian :-)

> > But it is not only usbutils that is broken, I first noticed breakage
> > on android fastboot.
>
> Android needs it? That's crazy, given that they don't have any usb host
> controllers in their devices. Very wierd...

fastboot runs on PC and uploads kernels to Android device(s).

> Anyway, this change is going to be reverted, it is already queued up to
> go to Linus early next week. Just need to test some other pending
> patches as well.

Thanks!
Pavel

--
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html


\
 
 \ /
  Last update: 2009-07-11 22:49    [W:0.859 / U:0.056 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site