lkml.org 
[lkml]   [2009]   [Jun]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [BUG] GM45 blanks shortly after boot in 2.6.30-git
On 06/25/2009 06:41 PM, Jesse Barnes wrote:
> On Thu, 25 Jun 2009 10:30:23 +0200
> Andres Freund<andres@anarazel.de> wrote:
>
>> Hi,
>>
>> Somewhere between:
>> 03347e2592078a90df818670fddf97a33eec70fb (2.6.30 + 5415 commits)
>> and
>> c82e6d450fda56cb2d4f68534173d3cd11b32f9f (2.6.30 + 8722 commits)
>> my Laptop (Lenovo T500) with an Intel GM45 graphics card blanks
>> display during boot (before starting with initramfs) , stops
>> responding to anything (i.e. no caps-lock light) and shows no further
>> activity (i.e. no hdd activity).
>>
>> Before the blank I did not see any sign of a backtrace or similar,
>> but its hard to say there wasn't any. Unfortunately atm I don't have
>> another computer nearby, so I could not get a network console output
>> yet.
>
> So the i915 driver probably loaded and turned off your display, either
> by programming a bad mode or misdetecting something else...
>
>> Any other information needed?
>
> Can you try loading the drm module with debug=1? That should give us
> some more info about what's going on.
Is the information from the failed or from the working boot interesting?

> A bisect would help too of course...
I am now in the middle of bisecting (currently at d888a4c) and
interestingly the original problem does not occur at that commit, but
the modes of my external monitor get misdiagnosed (no 1680x1050
resolution anymore) - the internal one works fine.
That happended somewhere between 0a4de47 and d888a4c. I will skip this
issue for now and keep bisecting the old issue.

Andres


\
 
 \ /
  Last update: 2009-06-27 01:33    [from the cache]
©2003-2011 Jasper Spaans. Advertise on this site