lkml.org 
[lkml]   [2009]   [Jun]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] LED: Reply-To: use correct name for /sys/devices/virtual/leds/ entries
From
Date
On Wed, 2009-06-24 at 15:33 -0700, Greg KH wrote:
> From: Olaf Hering <olh@suse.de>
>
> This is needed to get kde-powersave to work properly on some g4
> powerbooks.
>
> From: Olaf Hering <olh@suse.de>
> Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>

I'm ok with this apart from:

> --- a/drivers/leds/ledtrig-default-on.c
> +++ b/drivers/leds/ledtrig-default-on.c
> @@ -23,7 +23,7 @@ static void defon_trig_activate(struct l
> }
>
> static struct led_trigger defon_led_trigger = {
> - .name = "default-on",
> + .name = "default::on",
> .activate = defon_trig_activate,
> };

which doesn't seem to match the patch description. Why does the trigger
name need to be changed?

Cheers,

Richard


--
Richard Purdie
Intel Open Source Technology Centre



\
 
 \ /
  Last update: 2009-06-25 13:03    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site