[lkml]   [2009]   [Jun]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    Patch in this message
    Subject[PATCH 2/3] Fix oops when closing ACM tty device right after open has failed.
    This commit 10077d4a6674f535abdbe25cdecb1202af7948f1 has stopped
    checking if there was a valid acm device associated to the tty, which is
    not true right after open fails and tty subsystem tries to close the

    As an example, open fails with a non-existing device, when probe has
    never been called, because the device has never been plugged. This is
    common in systems with static modules and no udev.

    Signed-off-by: Thadeu Lima de Souza Cascardo <>
    drivers/usb/class/cdc-acm.c | 2 +-
    1 files changed, 1 insertions(+), 1 deletions(-)

    diff --git a/drivers/usb/class/cdc-acm.c b/drivers/usb/class/cdc-acm.c
    index 02eb60b..3f10459 100644
    --- a/drivers/usb/class/cdc-acm.c
    +++ b/drivers/usb/class/cdc-acm.c
    @@ -677,7 +677,7 @@ static void acm_tty_close(struct tty_struct *tty, struct file *filp)

    /* Perform the closing process and see if we need to do the hardware
    shutdown */
    - if (tty_port_close_start(&acm->port, tty, filp) == 0)
    + if (!acm || tty_port_close_start(&acm->port, tty, filp) == 0)
    acm_port_down(acm, 0);
    tty_port_close_end(&acm->port, tty);

     \ /
      Last update: 2009-06-24 23:37    [W:0.078 / U:19.444 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site