lkml.org 
[lkml]   [2009]   [Jun]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] pata_rdc: driver for RDC ATA devices
From
Date
On Wed, 2009-06-24 at 18:10 +0100, Alan Cox wrote:
> From: Alan Cox <alan@linux.intel.com>
> diff --git a/drivers/ata/pata_rdc.c b/drivers/ata/pata_rdc.c
> new file mode 100644
> index 0000000..0f40cab
> --- /dev/null
> +++ b/drivers/ata/pata_rdc.c
[]
> +static void rdc_set_piomode(struct ata_port *ap, struct ata_device *adev)
> +{
[]
> + static const /* ISP RTC */
> + u8 timings[][2] = { { 0, 0 },
> + { 0, 0 },
> + { 1, 0 },
> + { 2, 1 },
> + { 2, 3 }, };
[]
> +static void do_rdc_set_dmamode(struct ata_port *ap, struct ata_device *adev)
> +{
> + static const /* ISP RTC */
> + u8 timings[][2] = { { 0, 0 },
> + { 0, 0 },
> + { 1, 0 },
> + { 2, 1 },
> + { 2, 3 }, };

Maybe consolidate?

The code seems to have many magic constants that might
be better #define'd and or'd.



\
 
 \ /
  Last update: 2009-06-24 18:41    [W:0.043 / U:0.084 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site