lkml.org 
[lkml]   [2009]   [Jun]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH for mmotm 2/5]
On Thu, Jun 11, 2009 at 06:26:48PM +0800, KOSAKI Motohiro wrote:
> Changes since Wu's original patch
> - adding vmstat
> - rename NR_TMPFS_MAPPED to NR_SWAP_BACKED_FILE_MAPPED
>
>
> ----------------------
> Subject: [PATCH] introduce NR_SWAP_BACKED_FILE_MAPPED zone stat
>
> Desirable zone reclaim implementaion want to know the number of
> file-backed and unmapped pages.
>
> Thus, we need to know number of swap-backed mapped pages for
> calculate above number.
>
>
> Cc: Mel Gorman <mel@csn.ul.ie>
> Signed-off-by: Wu Fengguang <fengguang.wu@intel.com>
> Signed-off-by: KOSAKI Motohiro <kosaki.motohiro@jp.fujitsu.com>
> ---
> include/linux/mmzone.h | 2 ++
> mm/rmap.c | 7 +++++++
> mm/vmstat.c | 1 +
> 3 files changed, 10 insertions(+)
>
> Index: b/include/linux/mmzone.h
> ===================================================================
> --- a/include/linux/mmzone.h
> +++ b/include/linux/mmzone.h
> @@ -88,6 +88,8 @@ enum zone_stat_item {
> NR_ANON_PAGES, /* Mapped anonymous pages */
> NR_FILE_MAPPED, /* pagecache pages mapped into pagetables.
> only modified from process context */
> + NR_SWAP_BACKED_FILE_MAPPED, /* Similar to NR_FILE_MAPPED. but

comment it as "a subset of NR_FILE_MAPPED"?

Why move this 'cold' item to the first hot cache line?

> + only account swap-backed pages */
> NR_FILE_PAGES,
> NR_FILE_DIRTY,
> NR_WRITEBACK,
> Index: b/mm/rmap.c
> ===================================================================
> --- a/mm/rmap.c
> +++ b/mm/rmap.c
> @@ -829,6 +829,10 @@ void page_add_file_rmap(struct page *pag
> {
> if (atomic_inc_and_test(&page->_mapcount)) {
> __inc_zone_page_state(page, NR_FILE_MAPPED);
> + if (PageSwapBacked(page))
> + __inc_zone_page_state(page,
> + NR_SWAP_BACKED_FILE_MAPPED);
> +

The line wrapping is not necessary here.

> mem_cgroup_update_mapped_file_stat(page, 1);
> }
> }
> @@ -884,6 +888,9 @@ void page_remove_rmap(struct page *page)
> __dec_zone_page_state(page, NR_ANON_PAGES);
> } else {
> __dec_zone_page_state(page, NR_FILE_MAPPED);
> + if (PageSwapBacked(page))
> + __dec_zone_page_state(page,
> + NR_SWAP_BACKED_FILE_MAPPED);

ditto.

> }
> mem_cgroup_update_mapped_file_stat(page, -1);
> /*
> Index: b/mm/vmstat.c
> ===================================================================
> --- a/mm/vmstat.c
> +++ b/mm/vmstat.c
> @@ -633,6 +633,7 @@ static const char * const vmstat_text[]
> "nr_mlock",
> "nr_anon_pages",
> "nr_mapped",
> + "nr_swap_backed_file_mapped",

An overlong name, in my updated patch, I do it this way.

"nr_bounce",
"nr_vmscan_write",
"nr_writeback_temp",
+ "nr_mapped_swapbacked",


The "mapped" comes first because I want to emphasis that
this is a subset of nr_mapped.

Thanks,
Fengguang


\
 
 \ /
  Last update: 2009-06-12 01:33    [W:0.514 / U:0.080 seconds]
©2003-2011 Jasper Spaans. Advertise on this site