[lkml]   [2009]   [May]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC PATCH 3/3a] ptrace: add _ptrace_may_access()
> Yeah.  And at the same time we might move it out of ptrace.c and give it
> a more descriptive name given that most users aren't related to ptrace
> in any way. may_inspect_task maybe? I'm good at naming things..

Yes, I would like to have it outside ptrace.c (I'd forgotten about that).
fs/proc/base.c is where most of the users really are, but CONFIG_PROC_FS=n
makes putting it there problematical.

The name probably should stay the same unless/until we rename the LSM hooks
to match. TBH, two separate hooks would make more sense to me than the
PTRACE_MODE_* argument. For the hook replacing PTRACE_MODE_READ, the name
may_inspect_task is apropos (not that I am attached to any given name).


 \ /
  Last update: 2009-05-06 23:13    [W:0.076 / U:1.116 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site