lkml.org 
[lkml]   [2009]   [May]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [Bug #13116] Can't boot with nosmp
From
On Tue, Apr 28, 2009 at 3:14 PM, David Rientjes <rientjes@google.com> wrote:
> On Sun, 26 Apr 2009, Dan Williams wrote:
>
>> Rafael J. Wysocki wrote:
>> > This message has been generated automatically as a part of a report
>> > of recent regressions.
>> >
>> > The following bug entry is on the current list of known regressions
>> > from 2.6.29.  Please verify if it still should be listed and let me know
>> > (either way).
>>
>> This is still unresolved.
>>
>> Stephen, please send your config.
>>
>
> Given the stack for the initial report, why would a config other than
> enabling CONFIG_DMA_ENGINE help if there's no ifdefs involved?

...because I have been unable to reproduce it and wanted to start
eliminating differences in our respective setups. I have booted an
oversubscribed (8-virtual / 2 physical cpus) kvm instance with 2.6.29
and have not seen this reproduce.

> This is happening in the for_each_possible_cpu() loop within
> dma_channel_rebalance(), which makes sense since the machine boots fine
> normally but not with `nosmp'.
>
> channel_table[] is not being initialized per-cpu for non-online cpus?

I'm grasping, but could this possibly be a kvm quirk whereby
cpu_possible_map gets out of sync with cpu_online_map in the 'nosmp'
case?

--
Dan
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2009-05-04 01:25    [W:0.100 / U:14.460 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site