[lkml]   [2009]   [May]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC PATCH 3/X] ptrace: introduce the empty "struct ptrace_task"
> Please use 'struct ptrace_context' and '*ptrace_ctx' instead.

I am fine with this name (or any other). But note in considering your
suggestions that we will shortly have another separate struct with a
similar name. The first one is the state of a ptrace tracee task (bits
about itself and pointing to its tracer). The second is the state of a
ptrace tracer (head of its tracees list, locks, etc).

A name like "ptrace_context" could be read as intuitive for either of these
two quite different things. Perhaps this is true of "ptrace_task" too,
though it seemed to us like it wasn't too unclear, and preferably shorter
than something like "ptrace_tracee_context".


 \ /
  Last update: 2009-05-26 22:37    [W:0.045 / U:5.956 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site