lkml.org 
[lkml]   [2009]   [Apr]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [patch 1/2] slub: rename cpuslab_flush to cpu_slab_flush
From
Hi David,

On Thu, Apr 23, 2009 at 9:38 PM, David Rientjes <rientjes@google.com> wrote:
> There is already a `cpu_slabs' file to display the number of cpu slabs,
> so cpuslab_flush should follow this pattern.
>
> The first documentation of this file will be in a subsequent patch that
> adds Documentation/ABI/testing/sysfs-kernel-slab, so no stable guarantee
> has been made that the name of this file would not change.

I'm afraid I don't have enough asbestos in my underwear to try to
sneak this one past Linus.

A kernel ABI is an ABI even if it's not documented. Now, I wouldn't
mind getting flamed if we actually gained something from the change.
But just fixing a simple typo in sysfs files is not big enough a
reason for me to merge the patch.

That said, I love the second patch though and am more than happy to take it.

Pekka


\
 
 \ /
  Last update: 2009-04-23 21:45    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site