lkml.org 
[lkml]   [2009]   [Apr]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH] netfilter: use per-cpu recursive lock (v11)
    On Tue, Apr 21, 2009 at 09:13:52AM -0700, Linus Torvalds wrote:
    >
    > Ok, so others already pointed out how dangerous/buggy this looks, but I'd
    > like to strengthen that a bit more:

    I believe that at least some of this is naming...

    > On Mon, 20 Apr 2009, Stephen Hemminger wrote:

    [ . . . ]

    > If you want a counting read-lock (in _order_ to allow recursion, but not
    > because the lock itself is somehow recursive!), then that function should
    > look like this:
    >
    > void xt_info_rdlock_bh(void)
    > {
    > struct xt_info_lock *lock
    >
    > local_bh_disable();
    > lock = &__get_cpu_var(xt_info_locks);
    > read_lock(&lock->lock);
    > }
    >
    > And then the "unlock" should be the reverse. No games, no crap, and
    > hopefully then no bugs. And if you do it that way, you don't even need the
    > comments, although quite frankly, it probably makes a lot of sense to talk
    > about the interaction between "local_bh_disable()" and the preempt count,
    > and why you're not using "read_lock_bh()".
    >
    > And if you don't want a read-lock, then fine - don't use a read-lock, do
    > something else. But then don't just re-implement it (badly) either and
    > call it something else!

    Sigh!!!

    Part of the problem is that back in 1971, Courtois, Heymans, and Parnas
    foolishly named their article "Concurrent Control with 'Readers' and
    'Writers'", which lead to the name "reader-writer lock". This started
    really biting around 1991, when Hsieh and Weihl created a reader-optimized
    lock similar to brlock, but with each of the per-CPU locks being
    exclusive rather than each being an rwlock.

    The problem was that Hsieh's and Weihl's lock was more than just
    a reader-writer lock. It could also be used (and -was- used) as a
    local/global lock, where for example you acquire your own lock to make
    local changes, and acquire all of the locks to obtain a consistent view
    of global state. In which case, you would read-acquire the lock in
    order to write, and write-acquire the lock in order to read. Blech.

    So, would it help if the function names names in this patch said something
    about "local" and "global" rather than "read" and "write"?

    Thanx, Paul


    > Linus
    >
    > PS: Ingo, why do the *_bh() functions in kernel/spinlock.c do _both_ a
    > "local_bh_disable()" and a "preempt_disable()"? BH disable should disable
    > preemption too, no? Or am I confused? In which case we need that in
    > the above rdlock_bh too.


    \
     
     \ /
      Last update: 2009-04-21 20:39    [W:2.439 / U:0.312 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site