lkml.org 
[lkml]   [2009]   [Apr]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 09/30] x86_64: ifdef out struct thread_struct::ip
From
Date
On Thu, 2009-04-09 at 20:53 -0700, Matt Helsley wrote:
> On Fri, Apr 10, 2009 at 06:35:22AM +0400, Alexey Dobriyan wrote:
> > struct thread_struct::ip isn't used on x86_64, struct pt_regs::ip is used
> > instead.
> >
> > kgdb should be reading 0, but I can't check it.
> >
> > Signed-off-by: Alexey Dobriyan <adobriyan@gmail.com>
> > ---
> >
> > arch/x86/include/asm/processor.h | 2 ++
> > arch/x86/kernel/kgdb.c | 2 +-
> > 2 files changed, 3 insertions(+), 1 deletion(-)
> >
> > --- a/arch/x86/include/asm/processor.h
> > +++ b/arch/x86/include/asm/processor.h
> > @@ -421,7 +421,9 @@ struct thread_struct {
> > unsigned short fsindex;
> > unsigned short gsindex;
> > #endif
> > +#ifdef CONFIG_X86_32
> > unsigned long ip;
> > +#endif
> > #ifdef CONFIG_X86_64
> > unsigned long fs;
> > #endif
>
> Do these make struct thread_struct behave better in cachelines (smaller,
> less aliasing)? Can we really fit more in the slab du jour?
>
> Otherwise it seems like we're littering these structs with #ifdefs
> and not really saving anything. If these #ifdefs don't save any space why not
> just put in a comment:
>
> > unsigned long ip; /* Used only on i386 */
>
> Or maybe even:
>
> union {
> unsigned long ip; /* Used only on i386 */
> unsigned long fs; /* Used only on x86_64 */
> };
>

Can we do it like this:
unsigned long ip_fs; /* ip: i386, fs: x86_64 */
I am using same variable for both cases, or we can use some better name than ip_fs.
I am assuming either it is i386 or x86_64 machine ;-)

--
JSR




\
 
 \ /
  Last update: 2009-04-10 06:17    [from the cache]
©2003-2011 Jasper Spaans