lkml.org 
[lkml]   [2009]   [Mar]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    SubjectRe: [BUG,2.6.28,s390] Fails to boot in Hercules S/390 emulator
    From
    Date
    On Tue, 2009-03-10 at 04:37 +0100, Frans Pop wrote:
    > On Tuesday 10 March 2009, John Stultz wrote:
    > > > After reverting 5cd1c9c5cf30 and the somewhat related 6c9bacb41c10 on
    > > > top of 2.6.28.7, the system boots OK again [1].
    > >
    > > Huh. No clue right off. What clocksource is in use on this system?
    >
    > $ cat /sys/devices/system/clocksource/clocksource0/current_clocksource
    > tod
    > (That's from 2.6.26.)
    >
    > > Also can you provide the output with the following patch?
    >
    > I already did something similar. Did you see my follow-up mail?

    No, sorry, I must have missed it.


    > I added:
    > + if (unlikely(clock->xtime_nsec < ((s64)xtime.tv_nsec << clock->shift)))
    > + printk("Negative result: %llu - %lld\n",
    > + (unsigned long long)clock->xtime_nsec,
    > + (long long)((s64)xtime.tv_nsec << clock->shift));
    >
    > Which resulted in:
    > Negative result: 166039808000 - 166039808256
    >
    > Would you still like me to try your patch?

    No no, I'll try to look again at your data in the morning.

    thanks
    -john




    \
     
     \ /
      Last update: 2009-03-10 04:45    [W:0.025 / U:30.704 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site