lkml.org 
[lkml]   [2009]   [Mar]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectResume failure: ata3.01: revalidation failed (errno=-2)
    Hi,

    I tried if I can get reliable suspend to RAM on my new Mac mini Core 2
    Duo using 2.6.29, and did a "burn in" test with an endless
    suspend/resume loop using RTC wakeup. After ~30 attempts, the kernel
    hangs with a screen full of this message:

    ata3.01: revalidation failed (errno=-2)

    In the kernel log, I see _one_ occurrence of this message at each resume:

    kern.debug: ata3.01: NODEV after polling detection
    kern.err: ata3.01: revalidation failed (errno=-2)

    I tried the same using 2.6.27.20 and got the same, after 52 attempts.

    The full kernel log is here:

    http://tikei.de/kernlog.txt

    This is the SATA device:

    00:1f.2 IDE interface [0101]: Intel Corporation 82801GBM/GHM (ICH7
    Family) SATA IDE Controller [8086:27c4] (rev 02)

    Any hints how I can fix or debug this? It looks like a generic message
    that only shows that something is wrong in a much deeper layer. Maybe I
    should add some debugging to ata_dev_revalidate().

    Regards,
    Tino


    \
     
     \ /
      Last update: 2009-03-25 07:47    [W:0.020 / U:0.060 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site