lkml.org 
[lkml]   [2009]   [Mar]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH -mm 1/6] slab: introduce __kfree_rcu
On Mon, 23 Mar 2009, Pekka Enberg wrote:

> > +static inline void *portion_to_obj(void *portion)
> > +{
> > + struct page *page = virt_to_head_page(portion);
> > + struct slab *slab = page_get_slab(page);
> > + struct kmem_cache *cache = page_get_cache(page);
> > + unsigned int offset = portion - slab->s_mem;
> > + unsigned int index = offset / cache->buffer_size;
> > +
> > + return index_to_obj(cache, slab, index);
> > +}
>
> A minor nit: I think this would be more readable if you separated
> variable declarations from the initializations. Also, you can probably
> drop the inline from the function declaration and let GCC decide what to
> do.

Thats debatable. I find the setting up a number of variables
that are all dependend in the above manner very readable. They are usually
repetitive. Multiple functions use similar initializations.



\
 
 \ /
  Last update: 2009-03-23 14:39    [W:0.152 / U:0.592 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site