lkml.org 
[lkml]   [2009]   [Feb]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 0/2] TPM: refactoring and integrity
On Mon, 2 Feb 2009, Rajiv Andrade wrote:

> This patchset contains a refactoring patch and integrity one. The first addresses Matt Helsley and Dave Hansen's comments on replacing the data[] vectors by packed structures making the code easier to read and debug and also consolidates most of the tpm_show_* functions. The second one provides an interface to read and extend PCR values, which is widely used by IMA.
>
> This version also addresses Matt Helsley's last observation on the timeout_t structure usage to access TPM_CAP_PROP_TIS_DURATION capability, now a new structure is being used, duration_t, whose fields now match exactly as defined in the TPM specification.
>
> Rajiv Andrade (2):
> TPM: sysfs functions consolidation
> TPM: integrity interface
>
> drivers/char/tpm/tpm.c | 528 ++++++++++++++++++++++--------------------------
> drivers/char/tpm/tpm.h | 142 +++++++++++++
> include/linux/tpm.h | 35 ++++
> 3 files changed, 423 insertions(+), 282 deletions(-)
> create mode 100644 include/linux/tpm.h

Applied to
git://git.kernel.org/pub/scm/linux/kernel/git/jmorris/security-testing-2.6#next

(For some reason, these ended up out of order in my mail folder which
upset git-am... fixed manually).

--
James Morris
<jmorris@namei.org>


\
 
 \ /
  Last update: 2009-02-03 01:29    [W:0.424 / U:0.044 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site