lkml.org 
[lkml]   [2009]   [Feb]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [patch 1/7] slab: introduce kzfree()
On Thu, 19 Feb 2009, Pekka Enberg wrote:
> Hugh Dickins wrote:
> >
> > But I fail to see it as a justification for kzfree(const void *):
> > if someone has "const char *string = kmalloc(size)" and then
> > wants that string zeroed before it is freed, then I think it's
> > quite right to cast out the const when calling kzfree().
>
> Quite frankly, I fail to see how kzfree() is fundamentally different from
> kfree(). I don't see kzfree() as a memset() + kfree() but rather as a kfree()
> "and make sure no one sees my data". So the zeroing happens _after_ you've
> invalidated the pointer with kzfree() so there's no "zeroing of buffer going
> on".

Well, that would be one way of picturing it, yes.
Imagine the "z" as for "zap" rather than "zero",
and the mechanism as opaque as Hannes suggests.

> So the way I see it, Linus' argument for having const for kfree() applies
> to kzfree().
>
> That said, if you guys think it's a merge blocker, by all means remove the
> const. I just want few less open-coded ksize() users, that's all.

I wouldn't call it a merge blocker, no; though I still
think it makes far more sense without the "const" there.

Hugh


\
 
 \ /
  Last update: 2009-02-19 21:43    [W:5.297 / U:0.000 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site