lkml.org 
[lkml]   [2009]   [Feb]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 1/1] trace: use the more accurate parameter.

* Frederic Weisbecker <fweisbec@gmail.com> wrote:

> On Mon, Feb 09, 2009 at 07:30:04PM -0500, Wenji Huang wrote:
> > Pass tsk to __update_max_tr instead of current to avoid latent hazard.
> >
> > Impact: clean up
> >
> > Signed-off-by: Wenji Huang <wenji.huang@oracle.com>
> > ---
> > kernel/trace/trace.c | 2 +-
> > 1 files changed, 1 insertions(+), 1 deletions(-)
> >
> > diff --git a/kernel/trace/trace.c b/kernel/trace/trace.c
> > index 5b1e9a9..c1592f1 100644
> > --- a/kernel/trace/trace.c
> > +++ b/kernel/trace/trace.c
> > @@ -335,7 +335,7 @@ __update_max_tr(struct trace_array *tr, struct task_struct *tsk, int cpu)
> > data->rt_priority = tsk->rt_priority;
> >
> > /* record this tasks comm */
> > - tracing_record_cmdline(current);
> > + tracing_record_cmdline(tsk);
> > }
>
>
> Indeed. At this stage, tsk is the next task in the middle of a context
> switch. So I guess current is right, but this is more proper to use tsk.

Rename it to 'next' then please.

Ingo


\
 
 \ /
  Last update: 2009-02-11 13:07    [W:2.411 / U:0.032 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site