[lkml]   [2009]   [Dec]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    Subject[patch 00/23] locking: name space cleanup and -rt spinlock annotation
    PREEMPT_RT needs to annotate spinlocks which cannot be converted to
    sleeping locks.

    The best name raw_spinlock is already taken by the low level
    architecture implementations. We tried to come up with a good name for
    those locks but none of the naming suggestions was really great.

    Linus finally suggested to cleanup the name space and rename the low
    level locks in the architecture code to arch_spinlock.

    The following patch series contains:
    - the name space cleanup
    - the new raw_spinlock implementation
    - annotation of the most important locks

    A git version of the series can be found here:

    git:// rt/locking



     \ /
      Last update: 2009-12-06 19:05    [W:0.020 / U:13.960 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site