lkml.org 
[lkml]   [2009]   [Dec]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
Subjectroot hub lost power or was reset
From
I've been getting a 45 sec
pause when waking my machine up
on the first cycle using s2ram.
At first thought it was udev, but later
am not sure it is. With further looking
if I remove the isight_firmware module from the kernel
suspend wakes up the first cycle as it should.(I don't have
isight-firmware-tools installed, leading me to believe this might
be the issue with isight-firmware.ko.)

Now looking at dmesg I see:

[ 413.551845] uhci_hcd 0000:00:1d.0: PCI INT A -> GSI 23 (level, low) -> IRQ 23
[ 413.551855] uhci_hcd 0000:00:1d.0: setting latency timer to 64
[ 413.551887] usb usb2: root hub lost power or was reset
[ 413.551927] uhci_hcd 0000:00:1d.1: PCI INT B -> GSI 19 (level, low) -> IRQ 19
[ 413.551937] uhci_hcd 0000:00:1d.1: setting latency timer to 64
[ 413.551967] usb usb3: root hub lost power or was reset
[ 413.552019] uhci_hcd 0000:00:1d.2: PCI INT C -> GSI 18 (level, low) -> IRQ 18
[ 413.552029] uhci_hcd 0000:00:1d.2: setting latency timer to 64
[ 413.552058] usb usb4: root hub lost power or was reset
[ 413.552094] uhci_hcd 0000:00:1d.3: PCI INT D -> GSI 16 (level, low) -> IRQ 16
[ 413.552104] uhci_hcd 0000:00:1d.3: setting latency timer to 64
[ 413.552134] usb usb5: root hub lost power or was reset
[ 413.552172] ehci_hcd 0000:00:1d.7: PCI INT A -> GSI 23 (level, low) -> IRQ 23
[ 413.552182] ehci_hcd 0000:00:1d.7: setting latency timer to 64
[ 413.552200] pci 0000:00:1e.0: setting latency timer to 64
[ 413.552217] ata_piix 0000:00:1f.1: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[ 413.552225] ata_piix 0000:00:1f.1: setting latency timer to 64
[ 413.554437] ata_piix 0000:00:1f.2: PCI INT B -> GSI 19 (level, low) -> IRQ 19
[ 413.554446] ata_piix 0000:00:1f.2: setting latency timer to 64
[ 413.554548] pci 0000:00:1f.3: PCI INT B -> GSI 19 (level, low) -> IRQ 19
[ 413.554559] pci 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 413.554567] pci 0000:01:00.0: setting latency timer to 64
for a bit I thought that this was also the cause of the delay
but the system wakes up as it should even with this happening to
usb.

BTW: Is CONFIG_USB_PERSIST in the kernel anymore
with 2.6.32*?(I can't seem to find that option);

--
Justin P. Mattock


\
 
 \ /
  Last update: 2009-12-02 23:37    [W:0.079 / U:0.184 seconds]
©2003-2014 Jasper Spaans. Advertise on this site