lkml.org 
[lkml]   [2009]   [Nov]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] longhaul: select Longhaul version 2 for capable CPUs
On Sat, 24 Oct 2009 23:28:14 -0400
Dave Jones <davej@redhat.com> wrote:

> On Sat, Oct 24, 2009 at 05:25:38PM +0200, Krzysztof Helt wrote:
> > From: Krzysztof Helt <krzysztof.h1@wp.pl>
> >
> > There is a typo in the longhaul detection code so only Longhaul v1 or Longhaul v3
> > is selected. The Longhaul v2 is not selected even for CPUs which are capable of.
> >
> > Tested on PCChips Giga Pro board. Frequency changes work and the Longhaul v2
> > detects that the board is not capable of changing CPU voltage.
> >
> > Signed-off-by: Krzysztof Helt <krzysztof.h1@wp.pl>
>
> It seems we deliberately changed this two years ago, though the changelog
> is a bit sparse on details..
>
> commit 07844252ffd81ec192a62014bada1016c9703765
> Author: Rafal Bilski <rafalbilski@interia.pl>
> Date: Sun Apr 22 12:26:04 2007 +0200
>
> [CPUFREQ] Longhaul - Revert Longhaul ver. 2
>
> There is something wrong with this code. It needs more
> testing. It is better to disable it for now because support
> for some machines will be broken.
>
> Signed-off-by: Rafal Bilski <rafalbilski@interia.pl>
> Signed-off-by: Dave Jones <davej@redhat.com>
>
>

Are there any chances this patch will go into the linux-next?

Regards,
Krzysztof

------------------------------------------------------------------------------
Strrraszny konkurs z Scooby-Doo!
Wez udzial >> http://link.interia.pl/f2412


\
 
 \ /
  Last update: 2009-11-03 20:35    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site