lkml.org 
[lkml]   [2009]   [Nov]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] strstrip incorrectly marked __must_check
> static inline void strsrip_tail(char *str)
> {
> char *x __used;
> x = strstrip(str);
> }

Bikeshed time but its cleaner to do

static inline __must_check void strstrip(char *str)
{
return strim(str);
}

and make strim() the old strstrip function without the check requirement


Alan


\
 
 \ /
  Last update: 2009-11-03 20:13    [W:0.078 / U:0.124 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site