lkml.org 
[lkml]   [2009]   [Nov]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH 1/4 tip/sched/core] sched: rename preempt_notifier to sched_notifier and always enable it

    * Tejun Heo <tj@kernel.org> wrote:

    > Rename preempt_notifier to sched_notifier, move it from preempt.h to
    > sched.h, drop sched_ prefixes from ops names and make sched_notifier
    > always enabled.
    >
    > This is to prepare for adding more notification hooks. This patch
    > doesn't make any functional changes.

    The sched notifiers and the various event notifiers we have in the same
    codepaths should really be unified into a single callback framework.

    We have these _5_ callbacks:

    ...
    perf_event_task_sched_out(prev, next, cpu);
    ...
    fire_sched_out_notifiers(prev, next);
    ...
    trace_sched_switch(rq, prev, next);
    ...
    perf_event_task_sched_in(current, cpu_of(rq));
    fire_sched_in_notifiers(current);
    ...

    That could be done with just two callbacks - one for sched-out, one for
    sched-in.

    The best way to do that would be to use two TRACE_EVENT() callbacks,
    make them unconditional and register to them. (with wrappers to make it
    all convenient to use)

    This requires some work but needs to be done.

    Ingo


    \
     
     \ /
      Last update: 2009-11-26 11:33    [W:0.021 / U:30.108 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site