lkml.org 
[lkml]   [2009]   [Oct]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH] ide: update Kconfig text to mark as deprecated
From
From: Robert Hancock <hancockrwd@gmail.com>
Date: Mon, 26 Oct 2009 19:41:32 -0600

> The current Kconfig text for CONFIG_IDE doesn't give a hint to users that this
> subsystem is currently in maintenance mode and isn't actively developed.
> Let's correct this by marking it as deprecated, and also get rid of a bunch of
> unnecessary text that doesn't really have anything to do with what the option is
> for.
>
> Signed-off-by: Robert Hancock <hancockrwd@gmail.com>

Applied to ide-next-2.6, thanks.

But honestly, we have to reword or revert this if certain
things don't happen before the next merge window.

What it comes to is that two things have to happen before
we can completely shut down IDE and schedule it's removal.

1) Add a way for the ATA layer to create compat device
nodes so that people can change over to use the ATA
layer for their devices without any fstab et al. changes.

These compat device nodes do not have to be so featureful
that they support hdparm or smartd or anything like that,
but they need to work well enough to mount filesystems, and
mount swap partitions, and interact with device management
systems like udev as if they were real IDE devices.

2) The two or so remaining devices which have IDE support but
don't have an ATA layer driver need porting.

I plan to work on #1 if I get the time. Someone with the requisite
hardware needs to work on #2, and I'm sure whoever wants to work on
that will find it easy to get help from some ATA layer experts.


\
 
 \ /
  Last update: 2009-10-29 11:15    [W:0.084 / U:0.284 seconds]
©2003-2014 Jasper Spaans. Advertise on this site