lkml.org 
[lkml]   [2009]   [Oct]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2 1/6] ACPI: dock: clean up error handling paths in dock_add()
* Dmitry Torokhov <dmitry.torokhov@gmail.com>:
> Hi Alex,
>
> On Wed, Oct 14, 2009 at 04:46:16PM -0600, Alex Chiang wrote:
> > Remove some copy/paste code in our error handling paths, which makes
> > the function smaller and slightly easier to read.
>
> Changing individual attributes into attribute_group would greatly
> simplify the code.

Good advice, I'll do this, thanks.

> > @@ -968,11 +968,9 @@ static int dock_add(acpi_handle handle)
> > platform_device_register_simple(dock_device_name,
> > dock_station_count, NULL, 0);
> > dock_device = dock_station->dock_device;
> > - if (IS_ERR(dock_device)) {
> > - kfree(dock_station);
> > - dock_station = NULL;
> > - return PTR_ERR(dock_device);
> > - }
> > + ret = IS_ERR(dock_device) ? PTR_ERR(dock_device) : 0;
> > + if (ret)
> > + goto out;
>
> I think
>
> if (IS_ERR(dock_device)) {
> ret = PTR_ERR(dock_device);
> goto out;
> }
>
> is more commonly used form.

Ok, I'll change to the more idiomatic form.

Thanks for the review.

/ac



\
 
 \ /
  Last update: 2009-10-16 23:19    [W:1.616 / U:0.004 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site