lkml.org 
[lkml]   [2009]   [Oct]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] atmel_serial: Fix bad BUILD_BUG_ON() usage
Nicolas Ferre ha scritto:
> Haavard Skinnemoen :
>> is_power_of_2() appears not to be constant enough for BUILD_BUG_ON()
>> after the latest rework, so replace it with an open-coded test.
>>
>> Signed-off-by: Haavard Skinnemoen <haavard.skinnemoen@atmel.com>
> Acked-by: Nicolas Ferre <nicolas.ferre@atmel.com>
>> ---
>> drivers/serial/atmel_serial.c | 2 +-
>> 1 files changed, 1 insertions(+), 1 deletions(-)
>>
>> diff --git a/drivers/serial/atmel_serial.c b/drivers/serial/atmel_serial.c
>> index 3551c5c..9d948bc 100644
>> --- a/drivers/serial/atmel_serial.c
>> +++ b/drivers/serial/atmel_serial.c
>> @@ -1531,7 +1531,7 @@ static int __devinit atmel_serial_probe(struct platform_device *pdev)
>> void *data;
>> int ret;
>>
>> - BUILD_BUG_ON(!is_power_of_2(ATMEL_SERIAL_RINGSIZE));
>> + BUILD_BUG_ON(ATMEL_SERIAL_RINGSIZE & (ATMEL_SERIAL_RINGSIZE - 1));
>>
>> port = &atmel_ports[pdev->id];
>> port->backup_imr = 0;
>
>

Hi all,

I was expecting this patch to be merged in 2.6.32-rc4...

Consider that without this change, the driver does not _even_ build
(that's why I think we shouldn't wait the next merge window...).

Regards,

Claudio




\
 
 \ /
  Last update: 2009-10-12 10:05    [W:0.047 / U:0.360 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site