lkml.org 
[lkml]   [2009]   [Oct]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] LED driver for Intel NAS SS4200 series (v3)
From
Date
On Mon, 2009-09-28 at 11:28 -0700, Joe Perches wrote:
> On Mon, 2009-09-28 at 10:51 -0700, Dave Hansen wrote:
> > On Thu, 2009-09-24 at 17:19 -0700, Andrew Morton wrote:
>
> Trivial logging comments:
>
> One of the printks is not prefaced and the printks
> and dev_printks are not consistently using either
> periods or no periods.
>
> Some possible substitutions:
>
> s/dev_printk(KERN_INFO/dev_info(/
> s/dev_printk(KERN_DEBUG/dev_dbg(/
> s/printk(KERN_INFO/pr_info(/
>
> I think it would be better to use:
> #define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
> and remove the "%s: " ... KBUILD_MODNAME

Those all sound like good suggestions and should clean things up.

> >+ printk(KERN_INFO KBUILD_MODNAME ": '%s' found\n", id->ident);
>
> Perhaps
> pr_info("Found a '%s'\n", id->ident);
>
> > + printk(KERN_DEBUG "setting blue off and amber on\n");
>
> pr_debug?
>
> > + printk(KERN_INFO "%s: skipping hardware autodetection\n",
> > + KBUILD_MODNAME);
> > + printk(KERN_INFO "\tif this works, please send the output ");
> > + printk(KERN_INFO "of 'dmidecode' to dave@sr71.net\n");
>
> I think this will look odd when printed.
> There's a tab on the second line, not on third.
> Perhaps:
> pr_info("Skipping hardware detection.\n");
> pr_info("Please send 'dmidecode' output to dave@sr71.net\n");
>
> > + printk(KERN_INFO "%s: no LED devices found\n",
> > + KBUILD_MODNAME);
> > + printk(KERN_INFO "registering %s PCI driver\n", KBUILD_MODNAME);
> > + printk(KERN_INFO "Unregistering %s driver\n", KBUILD_MODNAME);
>
> pr_info("No LED devices found\n");
> pr_info("Registering PCI driver\n");
> pr_info("Unregistering PCI driver\n");

Doing that really cleans things up nicely. Thanks for the suggestions!

-- Dave



\
 
 \ /
  Last update: 2009-10-02 00:07    [from the cache]
©2003-2011 Jasper Spaans