lkml.org 
[lkml]   [2009]   [Jan]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Too async libata breakage
On Thu, 8 Jan 2009 23:02:33 +0300
"Alexey Dobriyan" <adobriyan@gmail.com> wrote:

> > On Thu, 8 Jan 2009 22:15:56 +0300
> > "Alexey Dobriyan" <adobriyan@gmail.com> wrote:
> >
> > > commit f29d3b23238e1955a8094e038c72546e99308e61 aka
> > > "fastboot: Make libata initialization even more async"
> > > results in no findable /dev/sda2 to mount / here.
> > >
> > > Kernel correctly sees sda as 750GB drive and the rest too.
> > >
> > > CONFIG_ATA_PIIX is in use, everything built-in, plain partitions,
> > > no initrd, DM, MD etc.
> >
> > hmm.
> > no initrd;
> >
> > can you try an experiment?
> > if you edit init/do_mounts.c and find the "async_synchronize_full" call.
> > that is just after a while() loop.
> > Can you put another call to synchronize_full to also just before that
> > while loop and see if that fixes it ?
>
> Additional async_synchronize_full() helps and box boot to the end.

I just hit this bug, too. I don't have the kernel logs to attach here,
but it looks like sd has just found sda, when mounting root fs is
attempted, and sda partitions have not been read yet. This leads to
panic as root cannot be mounted. I have only tried
linus/master and Ingo's tip/master today, no bisecting.

My setup is Thinkpad T61, Core 2 Duo, a SATA disk, no initrd.

Adding rootdelay=5 allows me to boot properly, and so does the
experiment suggested above.

I'm not subscribed, so please cc me. Thanks.

--
Pekka Paalanen
http://www.iki.fi/pq/


\
 
 \ /
  Last update: 2009-01-08 21:21    [W:0.050 / U:9.316 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site