lkml.org 
[lkml]   [2009]   [Jan]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.6.29 -mm merge plans
(cc added)

On Tue, 6 Jan 2009 17:57:44 -0500
Christoph Hellwig <hch@infradead.org> wrote:

> On Mon, Jan 05, 2009 at 12:43:00AM -0800, Andrew Morton wrote:
> > generic-swap-sparc-rename-swap-to-swap_ulong.patch
> > generic-swap-iphase-rename-swap-to-swap_byte_order.patch
> > generic-swap-lib-sortc-rename-swap-to-swap_func.patch
> > generic-swap-introduce-global-macro-swapa-b.patch
> > generic-swap-ext3-remove-local-swap-macro.patch
> > generic-swap-ext4-remove-local-swap-macro.patch
> > generic-swap-sched-remove-local-swap-macro.patch
> > generic-swap-dcache-use-swap-instead-of-private-do_switch.patch
> >
> > Add a kernel-wide swap() macro, use it. Merge.
>
> Hmm, must have missed this when it went to lkml. Having this helper
> generic is a good idea, but swap is far too generic for something
> in kernel.h as indicated by the various renaming patches. How about
> swap_vars?
>

I thought that swap() was a good name, actually.

Sure, it's bold. But we only have one swap() implementation,
kernel-wide, forever, right? So what the heck: call it swap()!


\
 
 \ /
  Last update: 2009-01-07 00:23    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site