[lkml]   [2009]   [Jan]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
Subjectdevpts multiple instances feedback
I just took a look at the changes going into Linus current tree and
here's some feedback about the devpts multiple instances code:

- the ptmx node is quite useful, I think it should always be around,
even for normal devpts mounts. That way distros can slowly migrate
over to just using it by default and making the containers
interaction easier. It's also in many ways much nicer to have
all the pty handling in one filesystems instead of sometimes
using the character device.
- the 000 mode is very weird, given how the /dev/ptmx operates
it doesn't really make much sense to have it different than 0666
unless you want to disable ptys.
- why does pts_sb_from_inode have to check s_magic, I can't see
it ever used on an inode not from the devpts filesystem
- parsing the options twice is rather odd, I'd rather parse it into
a once allocated structure then passed on through the private
data void pointer into get_sb_nodev
- creating the ptmx node should happen inside devfs_fill_super
- once the ptmx mknod is gone I think new_pts_mount,
is_new_instance_mount, init_pts_mount and maybe even get_init_pts_sb
should be merged into devpts_get_sb to make the whole mounting
scenario easier to follow instead of having to jump through half
a dozen functions
- I think CONFIG_DEVPTS_MULTIPLE_INSTANCES is not a good idea,
it's not much code and could either be enabled unconditionally or
based on the presence of a generic namespaces config option.
(btw, this also applies to the other namespaces options, there's
not much of a reason to have millions of options for them,
one single option would be a lot easier for the user..)

 \ /
  Last update: 2009-01-03 16:55    [W:0.163 / U:3.836 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site