[lkml]   [2009]   [Jan]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC v2][PATCH]page_fault retry with NOPAGE_RETRY

* Andrew Morton <> wrote:

> I think that a good way to present this is as a preparatory patch:
> "convert the fourth argument to handle_mm_fault() from a boolean to a
> flags word". That would be a simple do-nothing patch which affects all
> architectures and which ideally would break the build at any unconverted
> code sites. (Change the argument order?)

why not do what i suggested: refactor do_page_fault() into a platform
specific / kernel-internal faults and into a generic-user-pte function.
That alone would increase readability i suspect.

Then the 'retry' is multiple calls from handle_pte_fault().

Or something like that.

It looks wrong to me to pass another flag through this hot codepath, just
to express a property that the _highlevel_ code is interested in.


 \ /
  Last update: 2009-01-27 00:59    [W:0.040 / U:4.504 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site