lkml.org 
[lkml]   [2008]   [Sep]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: hotplug create_slot hang
Alex Chiang wrote:
> * Yinghai Lu <yhlu.kernel@gmail.com>:
>> On Sat, Sep 6, 2008 at 2:50 PM, Alex Chiang <achiang@hp.com> wrote:
>>> * Yinghai Lu <yhlu.kernel@gmail.com>:
>>>> calling pci_hotplug_init+0x0/0x1d
>>>> pci_hotplug: PCI Hot Plug PCI Core version: 0.5
>>>> initcall pci_hotplug_init+0x0/0x1d returned 0 after 11 msecs
>>>>
>>>> calling acpiphp_init+0x0/0x5f
>>>> acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5
>>>> decode_hpp: Could not get hotplug parameters. Use defaults
>>>> pci_create_slot: created pci_slot on 0000:07:00
>>>> acpiphp: Slot [1] registered
>>>> decode_hpp: Could not get hotplug parameters. Use defaults
>>>> pci_create_slot: created pci_slot on 0000:0d:00
>>>> acpiphp: Slot [2] registered
>>>> initcall acpiphp_init+0x0/0x5f returned 0 after 105 msecs
>>> Is this the hang?
>>>
>>>> calling pcied_init+0x0/0x7b
>>>> pciehp: HPC vendor_id 8086 device_id 340a ss_vid 0 ss_did 0
>>>> pci_create_slot: inc refcount to 2 on 0000:07:00
>>>> pci_destroy_slot: dec refcount to 1 on 0000:07:00
>>>> pciehp: pci_hp_register failed with error -16
>>>> pciehp: pciehp: slot already registered by another hotplug driver
>>> This failure is by design -- we only allow one hotplug driver to
>>> claim a slot now, and it's "first one loaded wins".
>>>
>>> Unless you're talking about something else?
>> after
>>
>> pciehp: pciehp: slot already registered by another hotplug driver
>>
>> never go on...
>
> You said that it worked a few days ago, but is hanging now.
>
> Can you bisect it?
>
> Kenji-san, any ideas?
>

I'm sorry, but I don't have any idea so far.

Yinghai, does this happen even when pciehp is not configured?

Thanks,
Kenji Kaneshige



\
 
 \ /
  Last update: 2008-09-08 14:59    [W:0.036 / U:2.088 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site