lkml.org 
[lkml]   [2008]   [Sep]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [RFC] x86: io-apic - convert DO_ACTION macro into function
[Ingo Molnar - Mon, Sep 08, 2008 at 04:33:35PM +0200]
|
| * Cyrill Gorcunov <gorcunov@gmail.com> wrote:
|
| > Convert DO_ACTION macro into more obvious io_apic_modify_irq
| > function with callers
| > ---
| >
| > I found it more readable then original was. Especialy we could grep
| > the callers in normal way. It's just an attempt - free to drop this
| > patch. I hope I don't messed with all these masks :) So the question
| > is rather NOT about details but idea in general.
|
| yeah - getting rid of such macros is a very good idea in general.
|
| > io_apic.c | 102 ++++++++++++++++++++++++++++++--------------------------------
| > 1 file changed, 50 insertions(+), 52 deletions(-)
|
| that's non-trivial impact. Did the .o md5sum survive this transformation
| just fine? (in theory gcc should generate the same code - but it doesnt
| always do that across macro->inline function changes, so it's hard to
| validate these kinds of changes.)
|
| Ingo
|

ok, then I continue to work on this. I think I better check assembly code
to remain the same (in general since for example new for(;;) form is
completely different - in old code is inspired by the macroses who
could change 'entry' variable in theory - but now it will not be possible
and not needed so we could use more 'eye-candy' for(;;) form). Thanks
for comments.

- Cyrill -


\
 
 \ /
  Last update: 2008-09-08 16:47    [W:0.034 / U:3.000 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site