lkml.org 
[lkml]   [2008]   [Sep]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: bad DMAR interaction with iwlagn and SATA
From
Date
On Thu, 2008-09-25 at 15:11 +0200, Andres Freund wrote:

> I don't know if this is relevant, but I though i better report it.

Thanks. I've also been chasing a DMA corruption issue with iwlagn (on
powerpc).

> This was on fb478da5ba69ecf40729ae8ab37ca406b1e5be48 - sometime after 2.6.27-
> rc7
>
> I stumbled over two buglets:
> First:
> [ 4184.617392] DMAR:[DMA Read] Request device [03:00.0] fault addr fa946000
> [ 4184.617393] DMAR:[fault reason 06] PTE Read access is not set
> [ 4184.644081] iwlagn: Microcode HW error detected. Restarting.
> [ 4186.646000] psmouse.c: TouchPad at isa0060/serio1/input0 lost synchronization, throwing 1 bytes away.
> [ 4186.683034] Registered led device: iwl-phy0:radio
> [ 4186.683478] Registered led device: iwl-phy0:assoc
> [ 4186.683793] Registered led device: iwl-phy0:RX
> [ 4186.684094] Registered led device: iwl-phy0:TX
> [ 4186.689749] wlan0: authenticate with AP 00:1d:7e:42:fe:42
> [ 4186.691691] wlan0: authenticated
> [ 4186.691705] wlan0: associate with AP 00:1d:7e:42:fe:42
> [ 4186.696380] wlan0: RX ReassocResp from 00:1d:7e:42:fe:42 (capab=0x411 status=0 aid=2)
> [ 4186.696392] wlan0: associated
>
> Most of the time when this happened, the machine wasnt reacting for 1-3
> seconds and had audio buffer underruns, but I also had a hard lockup which I
> couldnt diagnose so far.

I suspect the hard lockup was due to a BUG_ON in the iwlagn driver, if
you can reproduce this either try applying the patch here [1] or going
to a VC to see if it crashes there. It's a BUG_ON in iwl-tx.c.

johannes

[1] http://article.gmane.org/gmane.linux.kernel.wireless.general/21226

[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2008-09-26 17:13    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site