lkml.org 
[lkml]   [2008]   [Sep]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [ath9k-devel] ath9k: massive unexplained latency in 2.6.27 (rc5, rc6, probably others)
    On Thu, Sep 18, 2008 at 12:00 PM, Steven Noonan <steven@uplinklabs.net> wrote:
    > On Thu, Sep 18, 2008 at 11:42 AM, Luis R. Rodriguez
    > <lrodriguez@atheros.com> wrote:
    >> On Thu, Sep 18, 2008 at 11:34 AM, Luis R. Rodriguez
    >>> irqpoll is a monster of evil and that should make your system crawl to
    >>> its knees. I would advise instead we work with you fixing the the
    >>> missed interrupts issue upon rmmod.
    >>
    >> Also, please provide the output of
    >>
    >> cat /proc/interrupts
    >
    > Note that the problem necessitating use of irqpoll in the first place
    > seems to only happen under certain conditions. I am unsure what these
    > conditions are. Before 'ath9k: connectivity is lost after Group
    > rekeying is done', I had used rmmod/modprobe as my solution to the
    > issue, which triggered the IRQ issue.

    I wonder if this is related:

    alcarin ~ # dmesg | grep GPE
    [ 0.166806] ACPI: EC: GPE = 0x17, I/O: command/status = 0x66, data = 0x62
    [ 685.409077] ACPI: EC: GPE storm detected, disabling EC GPE


    \
     
     \ /
      Last update: 2008-09-18 21:25    [W:0.020 / U:31.044 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site