lkml.org 
[lkml]   [2008]   [Aug]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [2.6.27-rc4-git4] compilation warnings
Jesse Barnes wrote:
> On Tuesday, August 26, 2008 8:20 am Greg KH wrote:
>
>> On Tue, Aug 26, 2008 at 11:37:46AM +0200, Rufus& Azrael wrote:
>>
>>> Hello all,
>>>
>>> Fresh 2.6.27-rc4-git4 causes these compilation warnings on my amd64 box
>>> with gcc-4.3.1 :
>>>
>>> drivers/pci/search.c: In function ‘pci_get_dev_by_id’:
>>> drivers/pci/search.c:284: attention : passing argument 1 of
>>> ‘pci_dev_put’ discards qualifiers from pointer target type
>>>
>>> following this commit : ebca4f1bce1eb7b91a63c515db66316db9391221 PCI: fix
>>> reference leak in pci_get_dev_by_id()
>>>
>> Ick, sorry about that, I said my fix was not even build tested :)
>>
>> Here's a fix for this, Jesse, care to forward this on?
>>
>
> Yeah, thanks Greg. Alex and I built& booted it, but obviously I missed the
> warning.
>
> Jesse
>
>
Hello Greg and Jesse,

I have tested this patch which works fine and the warning disappears,
thanks for all.

Regards.


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2008-08-26 18:23    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site