[lkml]   [2008]   [Aug]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: XFS noikeep remount in 2.6.27-rc1-next-20080730

On Fri, Aug 01, 2008 at 01:19:58PM +1200, Jasper Bryant-Greene wrote:
> I mount a bunch of XFS filesystems with "noikeep,attr2,noatime", and a
> couple also with "ro".
> Sometimes I want to remount one of the "ro" ones "rw", to make changes.
> This doesn't work anymore in 2.6.27-rc1-next-20080730. The last kernel I
> tried which it worked in was 2.6.26 release.
> luna ~ # mount -o remount,rw /usr
> mount: /usr not mounted already, or bad option
> luna ~ # dmesg | tail -n 1
> [18702.291344] XFS: mount option "noikeep" not supported for remount
> Is this intended behaviour?

Side effect of this commit:;a=commit;h=0327f9d799ebb96f67c80dd732b1fdb09527365e


FWIW, noikeep is the default, so you don't need to specify it.


Dave Chinner

 \ /
  Last update: 2008-08-01 09:33    [W:0.055 / U:1.828 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site